
Introduction to Modelling 

This is how your characters and scene objects are created. Anything imaginable can be built 

within Maya and by using a variety of techniques explained below.  

Modelling to Scale 

It is important to model to scale where 

possible. Especially if you plan to 

integrate realistic lighting and/or 

dynamics into your scene – these both 

rely heavily on accurate physical 

models. The first step is to decide what 

units to work with within Maya – In your Settings/Preferences > Preferences window go to the 

Settings category and choose your working units based on what will be most suitable for your 

current scene. 

If the Maya scene is set to metres, then a 

box that is one metre cubed in real life 

should be one unit long. Likewise if we are 

working in cm then a person should be 170 

units tall. This may seem outrageously large 

when we view it in Maya, especially 

compared with our grid which is now tiny in comparison. We can easily go and fix this however, 

by going into our Grid Options box Display > Grid □ and adjusting the Length and Width of our 

grid, and more importantly (because this will affect 

your top, front and side panels also) how often you 

want Maya to display grid lines. 

One note to make is that if you are modelling to scale, 

you are likely to ‘outgrow’ the camera’s range of view. 

The camera has a limited distance that it can view 

objects which is called the Far Clip Plane and can be adjusted in the attribute editor with the 

camera selected (remember you can select the current 

view camera in the viewport menu by selecting View > 

Select Camera). 

  



Primitives  

A Primitive is often the starting block of any model and will take a relatively simplistic form to 

be later sculpted into something more aesthetically appealing. The initial level of detail and 

starting geometry can be altered offering the modeller a greater level of control. Using the 

channels box (when initially created) you can edit aspects such as divisions, sections and 

spans, however once the geometry has been edited this feature cannot be used as you will 

notice some abnormal behaviour 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

NURBS Polygons Subdivs 



The Basics of Modelling 

Polygons 

Polygons allow for a simplified overall Modelling process, you can make fantastic looking 

models with only a handful of key tools. Its universal Modelling form often allows a simple 

interaction with external packages like Zbrush and Photoshop.  Creating “hard edges” is 

relatively effortless and often requires considerably less geometry than other means. Unlike 

NURBS, polygons will retain their form until rendered where at this point you can create a 

smoother appearance (first image). The biggest challenge arises when used within an organic 

model as each individual polygon is independent and just one edge or vertex out of alignment 

can become noticeable. It makes for good practice to keep polygon models in their lowest 

possible resolution and only to smooth (last image) in the final stages otherwise your scene 

can become unnecessarily large. 

 

 

 

 

 

 

 

 

 

 

 

 

  



Common Polygon Modelling Tools and Techniques 

Extrude 

Possibly the most commonly used tool within polygon 

modelling which allows you to create additional faces and 

manipulate them accordingly.  

Using the Tool: 

 RMB (hold) 

 Select Faces 

 Highlight appropriate faces 
 

 

 

 Navigate to (Polygon Menu set)  
       Edit Mesh > Extrude □ 
 

 

 

 

You will then be presented with a type of universal manipulator 

You can use the Translate, Rotate, and Scale attributes of the 
manipulator to move the extrusion in relation to the object. If 
however you would like your manipulator to act in accordance to 
the scene defaults (i.e. be able to extrude perfectly along the Y 
axis) before you click on the manipulator you will notice a little 
circular icon just outside the rotation ring. By pressing this you 
can alternate between the two, we recommend you try this so 
you have a better understanding before moving forward. 
  



Merge Vertex / Edges 

Vertex 

Firstly we’ll take a look at merging a vertex as they have two varied ways to get the same 

desired effect. 

1. Interactive Merge Tool – As you would assume is allows you to merge them 

interactively, to do this select your object then navigate to Edit Mesh > Merge Vertex 

Tool. You will notice the selected object will transfer into Vertex mode and you now 

have a + as a curser. To merge a vertex to another click on the one you want to move 

initially then select the target vertex illustrated below. If you click on the tools option 

box you can chose if it merges to the target or the mid-way point between the two 

vertices... 

 

 

 

2. Merge Vertex Tool – By default this tool will merge a vertex to a central position 

amongst those selected prior to the merge. You are also able to merge multiple points 

at once by shift selecting or highlighting a large section. To perform this action, 

navigate to Edit Mesh > Merge □. The slider represents the tolerated difference where 

it will actually perform a merge, if a vertex is too far away from the target to nothing will 

happen, if nothing happens increase the range and merge again.  

 

 

 

 

 

 

 

 

  



Edges 

Merging an edge is less commonly used and to do so is a very similar technique to that above 

but instead of selecting a vertex you select and edge Edit Mesh > Merge Edge Tool □. 

Deleting a Vertex or an Edge 

Polygon geometry is made up of edges, where those edges cross paths you will find vertexes 

and faces make up the gaps in between. By removing a face there are no further implications 

as the surrounding geometry is untouched. If you remove an edge or vertex there are 

potentially side effects such as those illustrated below. You can clearly see that if the two long 

edges are removed along the centre by pressing delete, they leave behind the intersections 

making one line appear as three.  

 

 

 

 

 

 

The resolution to the above issue is simple, you select the edges in the same fashion but 

instead of using the delete key you have to use the Delete Select Vertex / Edge Tool. This 

way you will not leave behind any unwanted geometry, keeping your model as clean as 

possible. 

 

 

 

 

 

 

  

Broken Lines (Vertex points still 

remain) 

Complete Lines (Vertex points 

removed) 



Split Polygon Tool 

This tool is used for splitting individual faces of polygons, often used when altering the topology 

(edge flow) of any character/model. We will delve further into its uses at a more appropriate 

time. If you wish to access this tool, navigate to (Polygon Menu Set) Edit Mesh > Split Polygon 

Tool, once you are happy with your split; press the enter key to finalise. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



Cut Faces Tool 

This tool quite literally allows you to slice through your geometry paying no particular attention to 
edge flow, shape sides or holes in geometry: 
 
 
 
 
 
 
 
 
 

 

Edge Loop  

An “Edge Loop Tool” as the name would suggest adds a complete looping edge around your 

geometry, whilst taking into account edge flow unlike the “Cut Faces” tool. The loop will 

complete full circle (2) unless it meets one of the following issues: 

 Poly face that doesn’t equate to having 4 sides (1) 

 Geometry ends or vertices/edges may not be joined (3). 

 

Note: If you were expecting it to loop around 

and it doesn’t, investigate the area in which 

the flow seize to locate your issue. 

 

 

 

  



Common NURBS Modelling Tools and Techniques 

The initial few techniques (Loft, Revolve and Boundary) involve creating curves then using 

them to create the required geometry. Therefore before we delve into Nubs familiarize yourself 

with the functionality of curves and how they need to be constructed. 

CV Curve Tool  

CV Curves in essence are NURBS Curves with editable Control Vertices; each vertex however 

will not lie directly on the curve, as each of them represents points on a control lattice that 

encompasses the entire curve. You can however enter Edit Point mode to adjust vertices 

within the curves Marking Menu. 

EP Curve Tool 

Edit point curve tool will create curve points to follow exactly, you can however select CV’s 

within the Marking Menu which will then alter the way in which the curve is interact with.  

Bezier Curves:  

Bezier curves have always been used within Mayas Hypergraph however these have been 

recently transitioned to the surfaces toolset. Bezier Curves are most commonly used in 

computer imaging software for smoothing out curves, but gained their notoriety when dealing 

with vector images as they provide the ability to be scaled indefinitely. 



  



NURBS & Curves 

NURBS (Non-Uniform Rational B-Splines) are very different to your conventional modelling 

tools; whereas polygons are rigid; NURBS create objects using curves and surfaces allowing 

for an interactive interpolated surface and are often used to re-create organic objects such as 

people and detailed mechanical objects. A popular modelling technique using NURBS it 

patchwork modelling, whereby you create sections of a model separately and joining them at 

them end (If necessary). They are also used in the early stages of Modelling as they enable 

you to achieve a quick and accurate 

overall representation of your model, 

to be then converted into polygons 

where more detailed aspects can be 

applied. Below you will see a CV 

curve revolved into a wine glass, 

and can hopefully 

appreciate how 

quickly some 

shapes could be 

achieved using 

this and similar 

methods. 

 

 

 

 

 

 

 

  



Creating a Curve 

To simply select either (CV or EP) curve, navigate to the Create menu ensuring you are 

(generally) in an orthographic camera (perspective camera not recommended for drawing 

curves), and repeatedly click until you have created the shapes outline. It makes for good 

practice that whenever you have a corner you apply at least 3 curve points to define it. 

Loft, Revolve, and Boundaries  

These three common techniques all stem from the creation of one or more EP/CV curves with 

the purpose of creating editable geometry. A revolve 

will use only 1 curve and in order to create its 

geometry it will “revolve” around its centre pivot (by 

default this will be the centre of the grid 0,0,0) creating 

elliptical objects. A loft uses two or more curves to 

create a surface panel and will subsequently pass 

through any amount of specified curves which will 

ultimately define the overall panel shape. The final 

one is the boundary which requires a closed group of 4 Curves (selected in a clockwise 

formation), creating geometry within the specified area.  

 
 
 
 
 
 
 
 
 
 
 
 
 

  



Isoparms 

These allow you to add additional geometric 

lines providing more control over the specified 

area. When you have your NURBS shape, hold 

RMB to enter the marking menu, and “isoparm” 

(being the top option) will allow you to start 

placing them. Click on an already existing line to 

illustrate which curve you would like it to follow 

(horizontal/vertical) then drag appropriately, 

holding shift if you would like to enter more than 

one. To illustrate all pending isoparm placement  

you will see dotted yellow lines, to finalise the 

process and insert the isoparms navigate to Edit 

NURBS > Insert Isoparms.  

 
 
 

Control Vertex  

The same as a CV point on a single curve, you can manipulate each CV for each curve that 

makes up a NURBS surface. 

Hull 

A Hull is essentially a row or column of CV’s that makes up a NURBS surface. 

Surface Point 

As simple as it sounds, this indicates a specific point on a surface. Although this cannot be 

manipulated, you can select points on the surface in order to insert isoparm’s for example. 

  

  

 

  



NURBS Primitive Settings 

NURBS primitives by default are created with history based on a few common attributes. We 

will cover the most useful of these below. By creating the object with history, this also means 

that we can change the settings, such as the radius, even after the objects has been created, 

moved and modified. 

Sections 

Sections are used in spherical objects to 

control the resolution used; i.e. the number of 

isoparms to define the shape as 

demonstrated on the right. 

 

 

 

Start sweep / End sweep 

Spherical objects also have start and end 

sweeps. This is the angle at which the loft that 

creates these surfaces starts and ends as 

demonstrated on the right. 

 
 
 

 

 

 

 

  



Sub-Divisional Surfaces 

At a glance sub-divisional surfaces can often appear to offer the best of both worlds; allowing 

you access to the simplified polygon modelling form but the manoeuvrability of a NURBS 

surface, thus making it a popular method for creating organic models.  A big advantage is you 

can work in hierarchies from “0” (Base level) upward, but it’s wise not to enter above level 2-

3 if you wish to convert to polygons at any point. You have fewer vertices to manipulate the 

object but the hierarchical structure provides you with the ability to add detail without adding 

geometry, but they are not without their limitations. You will notice a vast reduction in tool set 

in comparison to polygons, but the biggest discrepancy of this method is undoubtedly the 

increase in render time, some results may be worth the increase but if you have a busy scene 

and limited time it could be worth considering converting them to an alternate form. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



Render Layers 

Similar to the above organisational structure this feature allows you to split up your renderable 

objects onto various layers or what is often referred to as render passes. Rendering in layers 

is an essential tool especially when it comes to the compositing stage as we will discuss in 

greater depth 

Layers give you a visual hierarchy which is useful in all areas of animation. This can be used 

to minimise the geometry in the scene, hide the rig etc. 

How to use the outliner: 

 

Task Details 

How to access  Window > Outliner 

Select a node (object) LMB click on the node 

Select multiple nodes LMB drag selection or Ctrl/Shift+LMB 

Create a group node Select group contents then press Ctrl+G 

Reorganise objects between 

groups 

MMB drag the node to the desired node 

Remove a group Highlight group and Ctrl+Shift+G 

Parent a node to another MMB the child under  the parent 

Un-parent a node MMB the child away from the parent 

Name / Rename a node LMB Double Click, then type in new name 

 

 

  



As a continuation from the introduction chapter on page 32, the outliner will help you to ensure 

you’re organised and structured. Initially this may seem pointless and mundane but by using 

simple naming techniques and hierarchies like those demonstrated below it will prove 

invaluable to you and colleagues as you progress towards more complex scene files. 

The below examples are taken from the same scene, hopefully you will understand why we 

are stressing the importance of this aspect. 

  Untouched    Organised 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



Image Planes 

Image planes can be very useful at the modelling stage; they allow you to keep the model 

accurate to their original drawings and maintain consistency throughout. An excellent website 

for acquiring these for free is www.the-blueprints.com here you will be able to download image 

planes for vehicles, electrical items, weapons, and various other miscellaneous items. 

On the other hand if you are solely working on a project as opposed to within a client based 

production team you may find it easier to have a few reference images of similar models, then 

use them as well as your creativity to model something truly original.  

Image Plane Setup 

Note: If you need assistance with preparing an image plane in Photoshop for use in Maya 

please refer to page 109 

Once your image has been prepared we will be looking at two methods of setting up an image 

plane. 

Importing an image onto a plane 

1. Create polygon Plane  

2. RMB > Click and drag down to Assign new Material > Lambert 

3. Common Material Attributes > Colour > Chequered box > File > image name (select 

file by clicking on the folder icon) 

 

Note: you may need to alter the UV settings (pg 81) or update the size of the image plane 

(Attribute editor > PolyPlane > PolyPlane History > width/height), to replicate exact 

dimensions.  

 

  

http://www.the-blueprints.com/


Importing an image onto a camera 

For good practice you can set up new orthographic cameras 

to hold reference image, however this comes down to 

personal preferences. To set up new cameras:  

In view pane: Panels > Orthographic > New...  

1 x Top (bottom may be required in some circumstances) 

1 x Side (only 1 pane is needed for symmetrical models) 

2 x front (you will need to rotate one of these 180° as well 

as adopting a suitable naming strategy [Img_Front, Img_Rear etc.). 

Import your images onto the camera: View > Image Plane > Import Image 

at this point in the attribute editor check the looking through camera option as opposed to "all 

views" (you might want to do this bit last so in the perspective view you can see the theory 

behind what happens next. 

Change 2 viewpoints to the new front and rear cameras (leaving the persp cam): Panels > 

Orthographic.... (Select Cam):  

By doing this you should have a similar setup to before, only some of your viewpoints are the 

new cameras 

  



View > Image Plane > Image Plane Attributes... Placement Extras > Centre... (Adjust the value 

in the last box (Z axis) to conflicting values one as 20, and one -20 (this may need to be 

adjusted depending on your grid size.  

Summary 

What this has effectively done is put a camera and image plane on either side of the grid. You 

will now only see the relevant image planes from the appropriate camera. 

Anatomy and Physiology 

Having an understanding of the basics of anatomy and physiology will undoubtedly assist you 

when it comes to creating your own characters; as allowing your edge flow to mimic human 

muscle structure is pivotal if you wish to achieve true to life deformations. 

You should research anatomy images and pay particular attention to muscle structure if you 

want to achieve realistic deformations.  

Tips before we begin Modelling Anatomy 

 Ensure you feel comfortable with the basics of polygon modelling as terms such as, 

extrude, merge, combine, and edge flow are used but not explained in this area of the 

book. Please refer to pages 49 - 59 for more information.  

 Familiarise yourself with the physiological makeup of the particular aspect you wish to 

model, as it will help you pre-visualise edge flow. 

 Having the correct edge flow from the outset will reduce the need for the split polygon 

tool. 

 Remember that image references for organic models may not always align perfectly 

like you can often get with blueprints. Therefore be aware of variances in angles, size 

and perspective; using them only as a guide to help maintain overall consistency. 

 Have real life images at the ready, if you’re using dual screens; plaster one side with 

reference images, as they will all assist you. 

 Remember once you have your base humanoid mesh you can manipulate this to 

adhere to the requirements of your specific model proportions (i.e. gangly arms) 

 Remember when using polygons, to use your smooth preview (using numbers 1,2 or 

3) to help pre-visualise your model you can model in any mode but we would always 

suggest referring make to the base mesh to “keep thing tidy”. 

Finally and possible one of the key points in modelling Keep the geometry as low as 

possible for as long as possible. 

 


